Locating Blow Up in Photoshop and Photoshop Elements

Question

I just bought the Photo Bundle and all plug-ins showed up in Photoshop except for Blow Up. It is not showing up in the filter menu like the rest of them.  Where can I find Blow Up? 

Answer

In regular Photoshop CS and CC, you will find it under the Filter > Alien Skin Blow Up 3. If it's not there, please look under File > Automation > Alien Skin Blow Up 3. 

If it's not in the Automate menu of Photoshop CC or CS5(and later), you can add it by following the instructions in this article.

In Elements, you will find Blow Up under the File > Automation Tools menu. If it is not there, please run the installer again.  If it is still not showing up, please contact our support team. One other thing of note in Elements 11 or later; you must make sure you are on the Expert tab in order to activate the Automation Tools menu. 

 


Have more questions? Submit a request.
Powered by Zendesk