Where is Blow Up 3?

Question

I’ve installed Blow Up 3 as part of the Exposure Bundle or on its own. Where is it? 

Answer

Blow Up 3 is designed to run as a plug-in for Photoshop, or as an external editor for Exposure or Lightroom. Here’s where to find it in each program.

Alien Skin Exposure

Right-click on an image. Select one of these options from the menu.

Edit Copy In ... > Blow Up 3
We recommend using this option to launch Blow Up. It will create a new TIFF copy of your image with Exposure’s adjustments applied and send that to Blow Up. 

Edit In ... > Blow Up 3
This option is useful if you want to resize the original image without retaining Exposure’s adjustments.
Note: This is will allow Blow Up to alter your original file.

Adobe Photoshop

Blow Up 3 is an automation plug-in accessed from the File > Automate menu, but we’ve added an option to show it alongside other Filter plug-ins in the Filters menu.

Filter > Alien Skin Blow Up 3
File > Automate > Alien Skin Blow Up 

Adobe Lightroom

Launch Blow Up from the Photo > Edit in > Blow Up 3 menu in Lightroom. You can also right-click the image you want to resize and choose: Edit in > Blow Up 3.

Running Blow Up in Standalone Mode

There is also a workaround that allows you to run Blow Up 3 as a standalone program.

Running Blow Up 3 In Standalone Mode


Have more questions? Submit a request.